Issues with Updating Content
Incident Report for Agility CMS
Postmortem

Incident

On October 4th, early in the morning, our systems reported that content was taking longer than normal to update. The outage prevented the latest content from being available through the Agility Content Fetch API. This resulted in content updates not being reflected on customer websites and apps that use this API.

Cause

The cause of the content processing delay was identified as a software defect in the logic around processing specific content events.

The Fix

A fix was implemented within hours to resolve the issue and successfully past our quality assurance. It was rolled out to all of our customers automatically.

Outcome

We were able to resolve the software defect within hours of the outage being detected and have implemented a fix to ensure that case cannot happen again.

Posted Oct 05, 2021 - 16:10 EDT

Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 12:18 EDT
Investigating
We are currently investigating some issues regarding updating content on our platform.
Posted Oct 04, 2021 - 10:26 EDT
This incident affected: Content Fetch API (REST/GraphQL).